PSU 2.0 upgrade - licensing died

Performed a zip installation of 2.0 under IIS, put my web.config back in place and everything seemed ok, then I noticed I was on the free trial again and not a full license. Pasting my license in as a new license didn’t work - just nothing happened when I hit ‘ok’. I thought perhaps the existing license was preventing me from re-adding so I tried to remove the existing license. That broke everything. Clicking on anything in settings resulted in errors of “d@https:///admin/static/js/18.0e570bf5.chunk.js:2:410361”, SyntaxError: JSON.parse: unexpected end of data at line 1 column 1 of the JSON data. I refreshed everything and was able to get back into settings, but starting any dashboard results in the same error. My alerts say the license was removed but it still shows up in the list of licenses applied. Scripts seem to run. Still on free version.

Edit: The error after trying to delete the license is actually TypeError: Object(…)().userData is undefined, and then the same admin/static/js errors.

Product: PowerShell Universal
Version: 2.0

Hey @jbennett_impact,

I can’t reproduce this myself. What happens if you add the license through the configurations page?


What browser are you using? Also, what license are you using? Standard or Offline key?

Hey Adam,
The license is present in the configurations/licenses.ps1. It never actually gets deleted. I’m using Firefox. Just tried removing the license with Chrome and got a slightly different error: TypeError: Cannot read property ‘roles’ of undefined, although it did in fact remove the license. Logging out and back in I was able to re-add the license, but it still shows I’m using the free version. I’m using the 499/year license.

For anyone running into a similar issue, it looks like the Standard license key (online activation) wasn’t working. The offline key does in fact work.

in my case the license remain active but in PSU the button for trial info when its clicked it shows


Yeah we noticed that too. I opened an issue for it here: Trial Info button is shown after licensing · Issue #200 · ironmansoftware/issues · GitHub