License not working on PSUD 2.9.0 (IIS)

Hey. License was working fine on the previous version (can’t remember which one I had) but when I upgraded to 2.9.0, the license is not working anymore. I have copied it to the net472 subfolder in the IIS app pool folder and restarted the app pool and website multiple times, still no dice.

I also tried adding “Set-UDLicense -License .\license.lic” in the dashboard.ps1 on the line preceding Start-UDDashboard but that didn’t work either.

Just to be clear: I removed all files from the app pool folder, except for dashboard.ps1, web.config, and license.lic and copied over new files from the PS module directory into it. It looks exactly the same as before upgrading.

Any tips?

I had the same with lic file in 2.9. Set-UDLicense does work but paste in the license key rather than referencing the license file…

You’ll want to put the license.lic file in the net472 in the module directory not in the IIS directory. We’ll be getting this fixed in the next version so it’s much easier to install the license…