Upgrade 2.0.0 -> 2.2.1 - "Error 500" when using PowerShell 7.0.3

Product: PowerShell Universal
Version: 2.2.1

We have just upgrade to version 2.2.1 from 2.0.0, from the .zip file.
After this our dashbord fails to start with a Error 500.
From looking on the forum it looks similar to Dashboard fails to start Error 500 - Ironman Software Forums
If I change it from the “Default” environment to “7.0.3” there is no difference, but if I change to “5.1.17763.1432” it will start.

The environment entry for “7.0.3” looks correct, and the path can be access/started.

Does anyone have any ideas or solutions?


What happens when you change the Environment assigned to the dashboard to 7.0.3 rather than the default environment?

I have tried all 3 (that I have):
“Default” - Error 500
“7.0.3” - Error 500
“5.1.17763.1432” - Starts

For some reason “7.0.3” refuses to start.

Ah, crap. I know what this is.

The current work around is to upgrade to PS 7.1

Confirmed, upgrading to PS 7.1.4 solved it.

Thanks for your help @adam, again :slight_smile:

1 Like