Unable to upgrade to 3.6.4

Product: PowerShell Universal
Version: 3.6.2
OS: Server 2019
Installer: MSI

Trying to upgrade a 3.6.2 install using the 3.6.4 MSI but immediately after launching the MSI I get the below error. Typical default configuration: (LiteDB) running as a service account that has local admin on the server and both the Repository and DB are located on the D: volume. Tried running the MSI as another local admin and then again as the service account it runs as, same error in both cases.


Can you share your appsettings.json file in C:\ProgramData\PowerShellUniversal?

An MSI log may also be helpful: logging - Create an MSI log file - Stack Overflow

Sure. Looking at the MSI log it appears that perhaps the MSI is appending my install path to the end of the default rather than replacing the default?

MSI (c) (78:A8) [15:47:09:319]: Doing action: SetINSTALLFOLDER
MSI (c) (78:A8) [15:47:09:319]: Note: 1: 2205 2: 3: ActionText
Action 15:47:09: SetINSTALLFOLDER.
Action start 15:47:09: SetINSTALLFOLDER.
MSI (c) (78:A8) [15:47:09:322]: PROPERTY CHANGE: Adding INSTALLFOLDER property. Its value is 'C:\Program Files (x86)\Universal;D:\Universal'.
Action ended 15:47:09: SetINSTALLFOLDER. Return value 1.

As I didn’t see a way to attach the log file to this post, I tried pasting the contents of the log file here but it gave me a max character length error for the post. If you need more than the lines I posted above to identify the issue, let me know the best method for me to get you the entire file.

Can you check the UAPATH environment variable? I know that others have had issues and deleting that may resolve it.