MSI Upgrade to 3.2.0 Issues - Failed


Tried upgrading to 3.2.0 today. Installer complained that the credentials were incorrect and asked to retry. I went into services and checked the credentials (including resupplying them), and hit retry.

Still keep getting the error message. Clicked cancel, says the changes were rolled back.
Went to go start the service and now complaining about the file/executable could not be found.

Tried restarting the install, and now it is asking me to setup all credentials, ports, and database again.
Have I lost everything?

Product: PowerShell Universal
Version: 3.1.6

You should still have an appsettings.json file in %ProgramData%\PowerShellUniversal. I would check to see if that is there. if it is, copy to a new location, then you could then do is install the 3.2, stop the service, place the appsettings.json back and start the service.

Also, there should be log files in there that should provide some more information as to what is causing the service to fail to start.

After I canceled the setup, trying to start the service produces:

I know the installer said the files were not modified because it was canceled, but looks like they were.
I do see my appsettings.json; the logs just show when I was running it previously. Nothing as to why the installer failed.

Two things I would check:

  • What’s in the C:\Program Files (x86)\universal folder
  • What’s in Add\Remove Programs with PowerShell Universal listed

Does not exist any longer.


It looks like it removed any trace. We had our instance on the D:, but I did check both locations just to be sure. We have our repository stored on a DFS share.

For anyone else running into this problem, I’ve added steps here: