Powershell Universal 3.2.0 service not starting


When I am trying to install PSU 3.2 running under a service account, I get the error:

Have added my service account to the policies mentioned in:

Any idea why I get the error, or is it isolated onto version 3.2? Running it with external SQL DB, and seems to be connecting just fine.

Hello @LinuxGuy

I ran into something similar; there was a change in 3.2 with SQL connections.

Please see this:
MSI Upgrade to 3.2.0 Issues - Failed - PowerShell Universal - Ironman Software Forums

I canceled at the time and redid it, but I am curious if you modified your appsettings.json while that message is up and retry would it work.

Hi Mike,

Already looked at that link but did not solve it.
How does your SQL connection string look like? I tried with this: Server=<db server>;Database=<db>;TrustServerCertificate=True;

Have tried removing the appsettings file after failure too, to make sure correct parameters were used.

Only thing I have in event manager is:
Product: PowerShell Universal -- Error 1923. Service 'PowerShell Universal' (PowerShellUniversal) could not be installed. Verify that you have sufficient privileges to install system services.

Product: PowerShell Universal -- Installation failed.

I would suggest doing an uninstall and then reinstall. During the reinstall, try to uncheck the service “Start service” check box. After install, try to set the service account manually in services.msc and see if the service starts up.

Hi Adam,

Seems to be a problem related to the RunAS function. Was able to install PSU without providing any credentials, but when I then insert my RunAS credentials afterwards in the Windows Service I get following:

Have added my RunAS credentials to the groups mentioned in: Running as a Service Account - PowerShell Universal

Already created a support ticket for your team.


One other thing I would suggest would be to check the permissions on the C:\ProgramData\PowerShellUniversal and C:\ProgramData\UniversalAutomation folders. Verify that the service account has access to these directories.


I had the same issue, I did a small work around and maybe it will help someone else.

  1. Manually created the user account (in the documentation, it’s not clear for me if it’s creating a user or of I need to create a user manually)
  2. Started MSI installer from a administrative Powershell session
  3. Followed all steps from the installer, until the error pops-up
  4. I forced closed the the MSI installer, from the process manager
  5. I set the NTFS owner and change permission (this will also enable write permissions) to the manually created service account
  6. Started the MSI installer again and the installation will finish without error


1 Like