Service cant be installed from MSI

Product: PowerShell Universal
Version: 3.0.1

I’m logged in as a domain admin and I’ve run CMD as ‘admin’ and run the MSI that way. The MSI installer gets to the service install and says I don’t have the perms. Win 19 Server.


I had the same issue, thinking it was because my user was in Azure AD and not “visible” for the log on as a service.

Turns out, it was some folders still left from older installations, so check if you have a folder in for example %appdata%(and other installation locations) and rename them(so that you have your content if its needed).

After I did this, the installatin worked fine for me.

1 Like

Thanks @TmJr75, this is a fresh server and no previous installs. I’m just logging in via AD identity that’s a domain admin.

Any other ideas?

Other tip from Adam in my thread was if I were using the SQL installation mode, to check the connection string (I did use SQL, but that was not the issue for me)

Just using the basic DB for me! Thanks for the response!

Have you tried / checked if your user is allowed to log on as a service? (start, run, secpol.msc)

I added myself and the service account to this policy, restarted. Still, no go. :frowning:

Can you try to install the service without setting the service account and then set it on the service in Service Manager after the install?

With PSU upgrades, we don’t touch the service so setting it like this will persist the account as well.

That worked, thanks Adam.

You may want to update the Upgrading documentation about this

To upgrade using the MSI, you can simply run the new version of the MSI. The MSI is setup to always perform a major upgrade. This means it will stop and remove the service, delete the entire installation directory, reinstall with the new files and then install and start the new service.

Nice catch. I’ll get this fixed.

I have this same issue. I tried installing without a service account, but the installation still fails. If I uncheck start service it installs fine, but the service will not start when I try to manually start it. This is a 2019 Server, and I am local admin, and have rights to logon as a service.