Unable to install service on new Windows Server 2022

Product: PowerShell Universal
Version: 3.4.4

I’m trying to install PU on a newly provisioned virtual server - Windows Server 2022 Standard. All patches are up-to-date and I also installed Powershell 7.2.7 and MS SQL Server Express 2019 (User databases and logs pointed to a separate D: drive). Everything installed from the same user account without problem.

However, when I try to install PU everything looks fine but it stalls on the final starting service step.
I’m not assigning a service account so it should run under the LocalSystem account. At first I tried installing PU to the same drive as the SQL databases and logs, but since that didn’t work, I tested installing to the default location instead. That didn’t help at all, same error at the end.

My intention is to run PU on the SQL server and I’ve tried a number of connection strings to see if that was the problem, but I’m pretty sure that’s not it. Particularly since I’ve also tried going with the default LiteDB option.

I see that the service is created in the Services.msc window, but it refuses to start.

I found this earlier thread with the same issue I’m having but the last post did not receive any feedback.

Kind regards

It should be generating logs in C:\ProgramData\PowerShellUniversal that will provide more info. You may also be seeing errors in the Application Log within Event Viewer that will provide more info.

That was fast! :smiley:
Sorry. Should have said.
No logs in C:\ProgramData\PowerShellUniversal but it created the AppSettings.json with my connection string(s).

However, the Application Log did have something.
Each time I ran the installer it seemed to generate two errors:
Event ID 1000:
Event ID 1026:

Seems to point to the SQL-server connection being the culprit, but I don’t understand why the attempt at installing with the default LiteDB fails as well then.

SQL-server is installed with Windows Authentication enabled.

I’ve tried using these connection strings to no avail:


No PSU database was created either.