Running Outside Commands in Module Doesn't Work

Is it possible to run other executables in PSU that would run fine at a standard PWSH terminal?

I tried wrapping napalm in a module to set if I could get it to work that way but still no dice. I continue to get the error [ERROR] ModuleNotFoundError: No module named ‘six’

I’m really hoping to get this to run so I can retrieve the results from the jobs db.

Product: PowerShell Universal
Version: 2.11.1

Update: I can get it to work on my laptop, just not the server

So kept getting a message stating that a certain library “six” wasn’t installed in Python although it was and would run from a separate pwsh instance. My solution was to “pip install napalm” from the PSU terminal and that did it!

1 Like

@cpsdakota, thanks for updating us to share your solution. It is appreciated.


Be advised that the -u parameter of python.exe may help if you’re having trouble seeing output from it in PSU.

-u : force the stdout and stderr streams to be unbuffered;
this option has no effect on stdin; also PYTHONUNBUFFERED=x