Cannot use Universal module commands

Product: PowerShell Universal
Version: 4.1.1

PS version: 5.1.20348.1850
Universal module version: 4.0.10

Running the following:

connect-PSUServer -ComputerName -UseDefaultCredentials

Getting the following exception:

Can you please help to understand what am I missing?

Any suggestions on the above?

I see you are using Powershell 5.

Do you get the same if you run Powershell 7?

I can see the cmdlet is marked unsafe. I wonder if there is any TLS1.2 related problems?

Tried from both PS 5 and PS 7.
It is not working.

Do I need to install something on the PSU server?
PSU running well.

Are you still on v 4.1.1?

Is this a Windows server or Linux container?

Can you specify OS version or exact image name too?

Thank you for trying to help me, appreciate it!

PowerShell Universal is: 4.1.5
Universal Module: 4.1.6

Operating System: Microsoft Windows Server 2022 Standard
Operating System Version: 10.0.20348

I also checked and all the DLLs in the module folder are not blocked.

This is an odd one.

Have any changes been made to your environments?

what does your environments.ps1 file currenlty look like?

I tried also to install the server and the module on my personal Desktop running Windows 10.
Same error on the same dll. It looks like something is missing or not working well.
Does someone know all the dependencies that this dll requires?

BTW, when I am running PS 7, I am getting always a 401 error, no matter if I am using default authentication and if I am using a valid token.

Any idea?