Powershell Pro Tools buttons not showing in VSCode

Tool: Visual Studio Code, PSScriptPad, PowerShell Module
Version: 2022.5.0

Hi,

we did an install on a secondary computer but somehow the buttons for compile, scriptpad, form designer and so on do not appear in the VSCode interface.

Running the packaging script from the command line also gives us a build error.
We explicitly approved the folder as trusted (I have seen this happen when the workspace is not trusted) but still no go.

We have installed the core .NET 6 SDK and the 4.8.2 SDK. Tried earlier versions of the plugin but all no go. Get-PoshProLicense gives us the instance is licensed. AV at first threw out PSscriptpad but we excluded the necessary directory and it shouldn’t bother with the extension at all anymore.

So we are wondering what is going wrong and what we could do about it.
Anyone out there with hints or tips?

What is the build error you are seeing? As for the button missing, make sure that you have these items checked in the settings.

image

Hi Lexence,

What you are trying to achieve will work on a healthy system. We know that your antivirus was triggered by PowerShell Pro Tools but I have doubts that all of the damage has been contained (or reverted). Perhaps other files have been convicted and sitting in quarantine?

You shouldn’t have to install anything extra to use PowerShell Pro Tools on a VS2022 installation (with the .NET desktop development workload enabled).

Some avenues to consider:

  1. Review the AV logs very carefully and the files within the quarantine storage to see what else might have been convicted. Really need to be sure that all files are being left alone and then perhaps do a reinstall until there’s no more impact.

  2. Try installing the needed apps on a clean workstation without the AV installed (if you have a dev environment where this is permitted). Enable features in the AV client 1 by 1 until you find the culprit that breaks the install. Could be time consuming.

  3. If you can reproduce this problem, raise a case with the AV vendor and see if they can help pinpoint the impact more precisely and how to configure the exception. They may have a diagnostic tool, debug logging etc. that can help provide more information. Most likely the problem lies with that the .exe file created will not have any reputation or provenance.

  4. If you were able to install on a clean machine, try comparing the contents of the folders that contain the related data. For example, the contents of the C:\Users[username]\PowerShellProTools\2022.5.0\windows folder.

Good luck. Please keep us updated.

Hi all,

sorry for my lack of response I had a week off.
first @adam:

We checked those bits, they are all enabled.

secondly @DataTraveler:

I will try and do this but we first turned of AV for the IronMan top level folder, removed all subfolders and then did a reinstall. So AV should no longer be an issue. Also we are using VS Core, not Visual Studio. So I don’t know if that changes anything.

thirdly, when we log in another user and set up the powershell pro tools and the powershell module for VSCode it seems to run perfectly fine. Maybe something is wrong with the powershell module for the original user. I will check.