PSScriptPad Ignoring Changes

Tool: Visual Studio, Visual Studio Code, PSScriptPad, PowerShell Module
Version: 5.1.18362.1714 | 5.13.3

Still having issues with modules not loading if I compile after launching PSScriptPad through VSCode. If I package by launching PSScriptPad and open the file there, the resulting EXE will load the modules. I happened to notice however that after adding a new button to my form, it doesn’t show up. I tried moving the script.ps1, script.designer.ps1 and script.resources.ps1 to a new location. Still doesn’t see the new button, but editing script.designer.ps1 you do see the button there.

How does one relink the resources to the script file or force it to refresh?

Let me try to reproduce this. I’ll let you know if I need more information.

I’m not seeing the issue of EXEs not updating. Can you share the output from the PSScriptPad console after running the packager?

I think I understand the issue with the modules not packaging correctly in VS Code now. I hope to have a fix for that in the 2021.9.0 release next week.