Power Shell Pro Installation issue with VS 2019 Enterprise

Greetings!
I have the same problem absolutely as in the case of this post Power Shell Pro Installation issue with VS 2019 Professional. But VS 2019 version is Enterprise.
The computer is not connected to the Internet.
A screenshot of the moment the installation started, and the installation log will be found in the attachment.
If you have a solution, please explain.

Hey @DramDream,

You will need to follow the offline certificate installation instructions in order to ensure the certificate can be trusted in an offline environment: Install certificates for an offline installation - Visual Studio (Windows) | Microsoft Docs

Hey @adam ,
The certificates for VS were installed during VS installation.
List of installed certificates:
Microsoft Code Signing PCA 2010
Microsoft Root Certificate Authority 2010
Microsoft Root Certificate Authority 2011
Should I install some kind of additional certificate?

You’ll also need to install the PowerShell Tools for Visual Studio extension to ensure our code signing certificate is installed as well.

At the beginning of the installation, the VSIX Installer reports “Digital Signature: Invalid Certificate”
At the end of the installation - “PowerShell Tools for Visual Studio has been successfully installed”
In the log file - “The extension with ID ‘PowerShellTools.VS2017’ is not installed to Visual Studio Enterprise 2019.”
Link to download the archive with screenshots and the log file - Microsoft OneDrive - Access files anywhere. Create docs with free Office Online.

Thanks for the logs. I’m trying to figure out why this is happening.

In the mean time, can you please try to install this unsigned version to see if it works around the problem?

@adam ,
I tried to install the extension from the link.
This version could not be installed either.
Upon a quick inspection, I saw that this version was not signed.
Link to download the archive with screenshots and the log file - Microsoft OneDrive - Access files anywhere. Create docs with free Office Online.

I’m going to have to do some additional debugging here to figure out what’s happening. It may take a few days before I can provide a resolution. I’ve open an issue in our tracker and will produce some documentation we can include on our docs site after I figure out what’s wrong.

Thanks @adam
I will wait for a solution to the problem

I just validated that these steps work: Visual Studio Offline Installation - PowerShell Pro Tools

The main thing that you need to do is install the certificate chain for PowerShell Tools into the target machine. This should resolve the issue with the invalid certificate.

@adam,
I will completely uninstall VS, and follow all instructions.
The installation report will come later.

Hey @adam,
I reinstalled VS. The current version is 16.11.0.
The certificates were installed according to your instructions.
When I run the installation of the extension, an error appears.
All information from the log is presented below:
8/27/2021 3:12:09 PM - Microsoft VSIX Installer
8/27/2021 3:12:09 PM - -------------------------------------------
8/27/2021 3:12:09 PM - Initializing Install…
8/27/2021 3:12:10 PM - Extension Details…
8/27/2021 3:12:10 PM - Identifier : PowerShellTools.VS2017
8/27/2021 3:12:10 PM - Name : PowerShell Tools for Visual Studio
8/27/2021 3:12:10 PM - Author : Adam Driscoll
8/27/2021 3:12:10 PM - Version : 5.10.2
8/27/2021 3:12:10 PM - Description : A set of tools for developing and debugging PowerShell scripts and modules in Visual Studio.
8/27/2021 3:12:10 PM - Locale : en-US
8/27/2021 3:12:10 PM - MoreInfoURL : PowerShell Pro Tools - Ironman Software
8/27/2021 3:12:10 PM - InstalledByMSI : False
8/27/2021 3:12:10 PM - SupportedFrameworkVersionRange : [0.0,2147483647.2147483647]
8/27/2021 3:12:10 PM -
8/27/2021 3:12:20 PM - Supported Products :
8/27/2021 3:12:20 PM - Microsoft.VisualStudio.Community
8/27/2021 3:12:20 PM - Version : [15.0.28010,17.0)
8/27/2021 3:12:20 PM -
8/27/2021 3:12:20 PM - References :
8/27/2021 3:12:20 PM -
8/27/2021 3:12:20 PM - Searching for applicable products…
8/27/2021 3:12:20 PM - Found installed product - Global Location
8/27/2021 3:12:20 PM - Found installed product - ssms
8/27/2021 3:12:20 PM - VSIXInstaller.NoApplicableSKUsException: This extension is not installable on any currently installed products.
at VSIXInstaller.App.InitializeInstall(Boolean isRepairSupported)
at VSIXInstaller.App.InitializeInstall()
at System.Threading.Tasks.Task.InnerInvoke()
at System.Threading.Tasks.Task.Execute()