Enable Authentication Not working in 1.5.13 Admin Console

Not sure if anyone else is seeing this, or has reported it yet. I recently upgraded my test system to the latest version, and noticed that I can no longer turn Authentication on/off through the Admin Console on an existing dashboard. If I chose Authentication when I created the dashboard, I can go in and hit the unlock to turn it off, but I cannot then go back in and turn it back on. I have to go to the Dashboards.ps1 file and set it manually.

My Prod server is on 1.5.11, and I did confirm I can still turn it off and on in this version, so not sure if it began in .12 or .13. I see in the ChangeLog for .13 where the ability to disable in the UI was added, not sure if re-enabling is even meant to be there, of disable only.

Edit: I should specify, sorry. This is if I am in the console, click on the Info icon for a dashboard, select Edit Properties, and then try to click on the lock/unlock icon. I can still change from Enabled to Disabled and back again on the main Dashboards view.

Product: PowerShell Universal
Version: 1.5.13

I’ll open a bug for this.

Thanks @Adam!