Dashboard controls disappeared from Admin console

Rebuilt our app services yesterday as we’re changing the name of our implementation and since the rebuild, it’s not showing us the console controls (start/stop, view details etc) for dashboards even though we’re logged in as full admins.

Can get to all the settings pages etc, and if I manually browse to /dashboards/3 (or any other) then I can see the management page for a dashboard, but still get no stop/start buttons.

This was happening on 2.6.2, have now upgraded to 2.7.0 and it looks the same.

Any thoughts/pointers?

Product: PowerShell Universal
Version: 2.7.0

Can you give some more information on your auth & roles method?
Have you tried enforcing the role to administrator under identities rather than letting it be policy defined?

Thanks for the reply @insomniacc :slight_smile:

Using Azure OIDC with Group Claims and then processed in roles.ps1 as below:

New-PSURole -Name "Administrator" -Description "Administrators can manage settings of UA, create and edit any entity within UA and view all the entities within UA." -Policy {
    param(
        $User
    )
    $User.HasClaim("groups", $env:ADMIN_ROLE_GROUPID)
}

All the groupids for the role groups are stored as environment variables, set by Terraform at build time - these all look fine and the roles get applied - dumping $roles into a UDList shows I’m a member of all the built in roles plus some of my custom ones:

image

The Admin role definitely has some of the effects I’d expect - if I take myself out of the role group and relogin so it no longer applies, I no longer see the security and settings menus in the admin console.

Adding Administrator directly under Identities has the same effect - although then I seem to be only able to apply one role - but still, no control buttons get displayed.

Wonder if this is a clue - we’ve recently set our git sync to one-way to resolve some merge conflicts:

Rebuilding with two-way sync re-enabled now… :crossed_fingers:

Yep, that got it - redeployed with two-way sync and it’s working like a charm.

@adam - is this something you’re aware of/expect? Can log as a bug if needed.

This is not something I’m aware of and would appreciate a bug report.

Here you go: Dashboard controls don't appear when GitSync is set to 1-Way · Issue #846 · ironmansoftware/issues · GitHub

1 Like