Webpage on IIS Not Updating

I am using a Windows Server 2016 Standard via IIS to deploy UD, but am running into issues. I used the following test code from Adam’s website

Start-UDDashboard -Wait -Dashboard (
New-UDDashboard -Title “Hello, IIS” -Content {
New-UDCard -Title “Hello, IIS”

Which worked perfectly, but when I added the number 2 to the end of “IIS” in the Dashboard and the Card, it won’t update. Tried in on other browsers and computers and it appears stuck. Perhaps a cache issue?

I had this same problem. Make sure you have -AutoReload on your Start-UDDashboard and are saving before testing. I also set IE on my IIS server to delete the cache every time it closed and I restart the site every change I make. Not sure which of those fixed it, but I can see every edit now.

What do you mean by restart the site?

In IIS, select the site folder (e.g ‘Default Web Site’) from the tree on the right. On the left pane, there are some actions at the top. One is ‘restart’. Click that to reload the site.

Have you recycled the application pool in IIS? That’s all that is necessary to pick up code changes.

Thanks for your help guys. It’s a simple AppPool recycle problem. I’m ashamed to say I was unfamiliar with them, as websites aren’t my main IT job.