VS Code Extension not connecting to Powershell Universal

Yesterday I’ve noticed that my VS Code extension no longer connects to our Powershell Universal instance.

I read there were also issues with Pro Tools, so I tried downgrading my Powershell extension, that didn’t seem to help much, but it’s the the only thing that changed recently that I know of.

I looked into the various commands that Universal add and found a generic “Connect” command, it didn’t come with the prefix “Powershell Universal” like the rest of the commands, and running it gave the following error:

I also tried the “PowerShell Universal: Start” which gave this error instead:

I’ve tried pretty much everything, reinstalling both Universal and the Powershell extensions, clearing the cache, basically anything short of nuking my entire VS Code install.

Running it in a clean profile produces an error “PowerShell Terminal is missing!”, so maybe it is the extension after all?

Product: PowerShell Universal (VS Code Extension)
Version: 3.0.0
VS Code Version: 1.69.2 (System Install)

This should be resolved in 3.0.1. The PowerShell team changed the name of the PowerShell Terminal which caused the extension to fail to load.