Not Connecting When Updating VS Code Extension

I’ve had version 1.6.1 of the PSU VS code Extension for a while now; I haven’t updated because the last time I tried I encountered issues where the extension would not connect. Unfortunately, there are a few bugs in my current version that require me to update such as:

  1. Scheduled Jobs not running
  2. When running one script manually all scripts run
  3. Deleting one scheduled job deletes several non related schedules jobs
  4. Dashboard shuts down randomly
  5. Dashboard does not restart automatically
  6. Scripts don’t synch up, if I make changes in VS Code the script in the Admin Console shows the old script.

Today I tried going from 1.6.1 to 1.7.4 and was hoping the previous update issues were gone but they are not. After updating, I open VS Code and it does two things: it tries to connect and a message to download PSU 1.5.13 is shown in the lower right corner. VS Code will try to connect, and fail, until I press the download button. As soon as I click it, all my files are loaded but I’m not able to open any of them as shown by the second picture. @adam

Product: PowerShell Universal
Version: 1.5.7

Are you hosting as Windows Service, or using IIS? Your pictures are too dark for me to make anything out regarding your configuration.

This is for my test environment so its just on a local machine. Having said that, I have a similar issue in Prod, which is using IIS; I have never been able to use VS Code there, all I’ve been using is the MSI install.

Are you using the default location for everything? If not, is your appsettings.json reflecting the correct file path?

Everything is using the default location. Everything works in version 1.6.1. As soon as I update, this happens.