Unable to add logo to navbar in PowerShell Universal with Git/SQL environment

Product: PowerShell Universal
Version: 3.8.11

I followed the instructions in the PowerShell Universal documentation to create a published folder using this link: Published Folders - PowerShell Universal. According to the documentation,

Published folders allow sharing of local folders through the Universal website. The files within the published folder should be accessible via a web request, which is useful for storing images or other files that you want to provide through your Universal Dashboard.

However, I am not sure I can use this methodology with a synced environment. My folder structure is synced to PSU with Git and looks like this:

I have attempted to access the AARLogo.png file in the pages folder with the following code snippet:

$Pages += New-UDPage -Name 'Manage Application Ownership' -Url '/ManageApplicationOwnership' -Logo "$UDScriptRoot\pages\AARLogo.png"

However, this did not work. I also tried traversing up the tree to another folder but to no avail.

I even tried using an image from GitHub at the dashboard level,

and I can right-click on the image and select Open Image in a New Tab to confirm that the image opens correctly. Is there perhaps a security or size restriction that I am not aware of?

@adam et.al., I would greatly appreciate any help or guidance that you can provide.