UD Enterprise Diagnostics

If you install tonight’s enterprise nightly build, you’ll be able to access diagnostics for your UD sessions.



i was testing your new added [Add telemetry for dashboard starts.] from github and for some reason one or more of these 6 files you have updated broke UD in IIS.

updating these 6 files broke UD and i could not start it in IIS.

I can look into it. Thanks for the heads up.

you are welcome.:slight_smile:

Will we be able to get the stats programmatically? That way we could gather the data if we have multiple sites - and build a sixth dashboard just for stats.

Also, cool! :sunglasses:

Yep! It has an API you can call to get all the stats.

When you find out something is wrong with your UD.

@adam hmm :bulb: UD-Diag !!!

Your reaction
giphy%20(2) giphy%20(1) !


hey @adam looks amazing! I tested this out using the default poshud dashboard within the module and works as expected, but when I test using my dashboard I get the following error - Cannot read property ‘map’ of undefined.

Something I’m missing here?

Probably a bug. Can you please press F12 and show me the console stack trace?

I’ve pushed some more changes to this feature. I added some code that should hopefully fix your issue, @mylabonline.

I’ve also made this feature opt in after some comments about security. I renamed the -Design flag to -AdminMode (Alias exists for backwards compatibility). When you turn that on, you’ll get all the features of AdminMode plus a Diagnostics page and a License page.


If you want to enable adminMode in production but don’t want everyone to see it, you can use the -AdminModeAuthorizationPolicy parameter of Start-UDDashboard to specify and authorizationPolicy to enforce who has access to adminMode.

Well that’s a great enhancement to a great enhancement :slight_smile: .

I’m guessing this will be in tonight build @adam?

Not sure if you still need the Console trace but see below.

Yep. This change was in last night’s build. Try and see if you still get that error. I’m not exactly sure what’s going on with that one. I think it might have to do with the size of the data being returned so I might need to change how that page is rendered.

I’m still getting an error when loading the diagnostics page with last nights build. I also tried loading the dashboard with the -AdminMode flag. I do see the FAB at the bottom but it does not have the additional buttons.


This was my bad. I was working on a branch that wasn’t merged to master so it didn’t make it into the nightly build. I’ve improved the performance of the diagnostics page so it won’t return so much data so hopefully it will load for you.

I’ve also added some more information around average endpoint execution time, user name and role \authorization policy info for the sessions.

awesome! looking forward to tonight’s build. I am running the most recent nightly build and I have noticed huge improvements during login and pages requiring authorization policies.

Loading pages with Authorization Policies start loading twice as fast :wink:


Any prediction on when this will be rolled into a gallery release?

Monday: https://github.com/ironmansoftware/universal-dashboard/milestone/27

1 Like

Hey @adam - Did this param get implemented? When I try and add the -AdminModeAuthorizationPolicy param I get an error “parameter cannot be found” I’m using the latest 2.7.0 release.

It’s actually on New-UDDashboard.

PS C:\Users\adamr> import-module universaldashboard
PS C:\Users\adamr> New-UDDashboard -AdminModeAuthorizationPolicy

Yip that did the trick! I was trying it on the Start-UDDashboard…

and the diagnostics page is now working with 2.7.0… Great enhancements!

1 Like