Universal Dashboard 2.8.2 Released

Universal Dashboard 2.8.2 has been released to the gallery. You can find more info here: https://github.com/ironmansoftware/universal-dashboard/blob/master/CHANGELOG.md


Hey @adam have you tested 2.8.2 in an Azure Web App? I cant seem to load anything it just hangs on a white page. I also loaded the poshud dashboard with the 2.8.2 module in the Web App and same result.

Just want to check to see if its a 2.8.2 problem of a config issue - I set the Web App to both .NET and .NET core and nothing. But If i redeploy 2.8.1 it loads correctly.

PoshUD.com is running 2.8.2 and it’s working. Try hard refreshing your page (Ctrl+F5). Maybe the JS is cached in the browser.

LOL oh man, yup that worked. Why is it the super technical stuff is “easy” but the obvious is the one that makes you want to take a nap.

Thanks Adam.

Don’t worry. I’ve had the same problem a million times and still have to take a nap. :wink:

This is actually something we can fix in UD. The problem is the endpoint doesn’t have a “version” on it so the browser has no way of knowing it’s changed.


Could become


ahhh makes sense - any fixes to make me nap less is best :slight_smile:

Thanks again Adam - I am also noticing some performance enhancements in 2.8.2 and memory usage in diagnostics is much lower (almost 50%)

Is there any documentation on the new admin mode? I just updated my test dashboard and i can’t figure out how to access the new Admin tools

It just works the same as before except that it’s a toolbar rather than a floating action button. You should see a black toolbar at the top of your page. I’ll update the docs today with new screenshots\info.

I dont see the admin toolbar either - only when i go to /admin/diagnostics i see the admin toolbar

but if i navigate to another page the admin toolbar goes away and my header comes back

Same here, only available on that page.

Also, the black bar covers half the title of the page.

What. The. Heck.

I have this working in UA.


What theme are you using? What browser?

Current version of chrome, running from powershell window.

Theme is azure.

It’s the Azure Theme. Default works fine but I see the same issue with Azure. Tabs are also miscolored in Azure.

I removed the -Theme param from my New-UDDashboard and the admin toolbar is now appearing (using the default)

I spend a few min digging into the html elements and found (in my theme) that its an issue of overlapping navbar with the admin toolbar. if i remove position: fixed from my css/theme for the ud-navbar I can now see the admin toolbar, but then totally breaks my whole top navigation.

can anyone confirm if in 2.8.2 they can still use $Session? I seem to have lost my session info.

Believe my $Session variables have fallen out. Tried reverting to 2.8.1 and they still don’t seem to be working, or my endpoints broke something fierce.

Hmmm. Can one of you guys file an issue with some details of the endpoints that are failing? We have tests for $session that aren’t failing so it’s a little weird this is happening but we should look into this.

Well, it appears after letting things run over night my $session stuff is looking better this morning.

But I have noticed something odd upon reverting to an older version- my search fields are being cached. Typically I have them pop out in a modal with information and upon closing the modal you are able to search for a new term, but for some reason it is now searching the old value instead. If you manually refresh the grid, it populates. Just an odd behavior.

Edit: Ignore this, found this lovely post and it resolved my issue. Forgot about Sync-UDElement.

Hey @adam I have opened an issue on GitHub

1 Like

Hey Adam,


seems to be broken as well.


1 Like