Tried to enable windows authentication - now IIS site is throwing an HTTP Error 500.30 - ASP.NET Core app failed to start


I have an PU instance running on an IIS. Everything was working. I wanted to add windows authentication and now my PU instance is broken:


I rolled back my changes to web.config and appsettings.json - they now look like this:

Web.config (seems to have added compared to a fresh web.config)
I have also tried coping over a new web.config with the correct arguments but that did not help


Changed value from true back to false

What did I mess up?

I noticed this ASP appearing in IIS - it was not there before

The authentication:

And lastly I was trying to remove the ASP in IIS and followed this guide:

  1. Open Server Manager and select the server name under Internet Information Services (IIS) Manager
  2. Double click HTTP Response Headers
  3. Remove the X-Powered-By header if it exists

Thats probably the reason the web.config was changed.

Should I just start over or can my instance be saved. Sorry for the long post.

Try changing hostingModel to “OutOfProcess” (hostingModel=“OutOfProcess”). I recall there being some strange issues with using inprocess.

Maybe @adam can elaborate on wether thats still an issue


Actually I ended up reinstalling the whole IIS. It was a big mess with several hosting bundles and other .net bundles.

Thanks though!

My IIS is up and running. Next task: Snapshot and backup of the server :smiley: