Rendering outside of "app"

I’m working on a implementation of react-window-modal

However, i’m met with a curious problem.
No matter how it’s passed, child endpoints are never rendered. I.E endpoints stuck on the suspense fallback “

Content is rendered correct, as long as the modal is loaded after the initial pageload.

My original belief was that this was caused by the react-window-modal component destroying the rendered modal, and moving it outside the

, to a child of , and the render service wouldn’t look for anything outside the id “app”.

So i tried to… ctrl+f+replace every reference of “body” (validating correct syntax etc) to have the modals built inside .app. Obviously the viewing was horribad, but the endpoints didn’t load.

Does anyone have any idea as to why? Am i missing anything obvious?
Or is this just a simple case of “won’t work in UD, sorry bro”?

Can you post a screenshots of how its behaving and will be helpful as well your .jsx code and ps1 as well.


hmm I think your proper is you didn’t invite your cape crusader partner to build it for you :rofl: post some code bro so we can all chip in

appreciate it @wsl2001 and @psDevUK

I gotta do some cleaning up first, kinda messed up the whole javascript library when i tried to debug live.

I’ll upload my current code to github when i’m done bingewatching Breaking Bad for the 3rd time O:-)

In your modal you need to return null.

1 Like

This might be the case, but i’m currently stuck.
Here is the github repo if anyone wants to give any feedback.

Beware: it is a copy paste from my ud-hotkeys control, hence certain elements might misreference to that module O:-)