PowerShell Universal v1.1.1

We just released version 1.1.1 of PowerShell Universal. It has a ton of fixes to get Dashboards working better. Your v2.9 and v3 dashboards should work. I think there will still be some bugs but it will be a huge improvement over 1.1.0.

We’ve also added Linux support and some little fixes here and there.

Read more here: https://ironmansoftware.com/powershell-universal-1-1-1/


Awesome! Will some of these fixes also be rolled into an updated Community release?

Universal Dashboard is now part of PowerShell Universal. We won’t be publishing UD stand alone at all. You can still run your UD Community dashboard for free within PowerShell Universal.

Existing UD dashboards (v2 and v3) should work in PowerShell Universal. I made a video on how to host them here: https://youtu.be/0Fu3PXZG3mU

The biggest reason for this change was it was a maintenance nightmare. Now that everything is under one umbrella it’s already been much easier to fix issues and implement new features. I would definitely suggest giving PSU a try and loading up your existing UD dashboard.

In PSU 1.2, we will be adding in REST API support, fixes to UDv2.9 and UDv3 as well a much easier way to configure PSU.

Feel like i have to be looking past the download on the downloads page, but i cannot find the link to download for the life of me. Am i crazy?

These are the downloads you’re looking for:


Recommendations on getting VSCode setup to utilize your beta frameworks for writing out the code? It seems like there are some changes and I can’t even get a basic dashboard up and running.

Couple of the errors popping:

 The term 'New-UDFooter' is not recognized as the name of a cmdlet, function, script file, or operable program.


Cannot bind parameter 'Dashboard'. Cannot create object of type "UniversalAutomation.Dashboard". The title property was not found for the UniversalAutomation.Dashboard object. The available property is: [Id <System.Int64>] , [Name <System.String>] , [FilePath <System.String>] , [BaseUrl <System.String>] , [DashboardFramework <UniversalAutomation.DashboardFramework>] , [PowerShellVersion <UniversalAutomation.PowerShellVersion>] , [ProcessId <System.Int32>] , [ProcessName <System.String>] , [Status <UniversalAutomation.DashboardStatus>] , [Authenticated <System.Boolean>] , [AutoReload <System.Boolean>]

my basic page

$page = New-UDPage -Name 'testpage' -Content {
New-UDParagraph -Text "Stuff"
$theme = . "C:\inetpub\portal\theme.ps1"

$mailtolink = New-UDLink -Url 'mailto:support@domain.com' -Text "Contact Us                                         "
$feedbacklink = New-UDLink -Url 'feedback.domain.com' -Text "Feature Suggestion and Bug Report"
$footer = New-UDFooter -Links @($mailtolink,$feedbacklink)

$sidenav = New-UDSideNav -Endpoint {
New-UDSideNavItem -Text "testpage" -PageName "testpage" -icon home
$dashboard = New-UDDashboard -Title "Automation Portal" -Pages $page -Theme $theme -footer $footer -navigation $sidenav

Start-UDDashboard -Dashboard $dashboard

To get it to work in VS Code:

You will need to also import the Universal module: https://www.powershellgallery.com/packages/Universal

Import the framework module: C:\ProgramData\PowerShellUniversal\Dashboard\Frameworks\UniversalDashboard\2.9.1-beta2

With 1.2 of PSU, we’ll start publishing the framework modules to the gallery so it’s easier to get them for VS Code. The UD framework modules will take a dependency on the Universal module so it should all come down when you install the framework module.

For your dashboard, it looks like we have some rough edges here. New-UDFooter is missing, the page doesn’t seem to work when there is a single item in it and the navbar isn’t showing items. Ugh.

I’ve opened issues to track all of this.

I dialed back the dashboard so I could get it to work in my end. You don’t need to call Start-UDDashboard any more. Just return the dashboard from New-UDDashboard.

$page = New-UDPage -Name 'testpage' -Content {
    New-UDParagraph -Text "Stuff"
    New-UDParagraph -Text "Stuff"
    New-UDParagraph -Text "Stuff"

$sidenav = New-UDSideNav -Content {
    New-UDSideNavItem -Text "testpage" -PageName "testpage" -icon home
    New-UDSideNavItem -Text "testpage" -PageName "testpage" -icon home
    New-UDSideNavItem -Text "testpage" -PageName "testpage" -icon home
    New-UDSideNavItem -Text "testpage" -PageName "testpage" -icon home

New-UDDashboard -Title "Automation Portal" -Pages $page -navigation $sidenav

Here is the example dashboard that we use for the automated tests if you need some examples. It’s funny because the tests have a pretty high pass rate but the simple stuff you tried isn’t working.

Always more work to do.

Also, if you do want to play with the v3 framework at all, this is the example dashboard for that: https://github.com/ironmansoftware/universal-dashboard/tree/master/src/v3/example

Thanks for the info. I got the universal module installed, getting error when trying to import the 2.9.1 beta.

Import-Module: Assembly with same name is already loaded

But, I got the dashboard running which was what I really wanted. I saw in the documentation how you are doing ldap for login and auth and that definitely has my attention, so I fired up the lab to start working on what that will look like for our environment. I only started on 2.9.1 because my existing dashboard is on 2.9. I will most likely be revisiting all my code when 3.0 is fully out in order to refactor and such for the changes you guys are making.

Cool thanks for giving it a shot. We hope to hit parity with PSU and UDv2 dashboards so people will mostly be able to just spin up their existing dashboard in PSU. So it’s good you’re trying stuff you expect to work in v2.

EDIT Nevermind, the problem listed below just seems to have needed more time to load the dashboard.

I started trying to work with PSUniversal and the 3.0 beta framework included on my existing UD Site. After a lot of commenting out to get started with a basic page I got to a landing at least. In an effort to understand and work with the v3 stuff, i took your whole v3 example on github and made a second demo dashboard out of it. This way i could just go to portal.domain.local/demo anytime and see the functionality, plus have the code on hand to understand.

The site is starting, but I reach an error landing of “There was an error starting this dashboard. Please contact your administrator.” Code is unchanged from your source, and the log section shows no errors, just loading of modules, commands and variables.


Looks like there was a bad merge up to the UD repo. I fixed it but I’m going to drop you with a nightly build since I didn’t test this on 1.1.1. The build is running right now and I’ll send you a link shortly. It has a lot of UD fixes.