Page Error DOCTYPE

PSU 1.3.0, 1.3.1nightly, UD 2.9.1beta6, 2.9.2nightly, pwsh through IIS (ad auth):

Im sure i am not the only one but i cannot find a thread about this, i get this on any error:

PowerShell Universal Dashboard body { display: flex; min-height: 100vh; flex-direction: column; } main { flex: 1 0 auto; } .v-wrap{ height: 100% !important; white-space: nowrap !important; text-align: center !important; display: block !important; min-height: auto !important; flex-direction: row !important; } .v-wrap:before{ content: ""; display: inline-block; vertical-align: middle; width: 0; /* adjust for white space between pseudo element and next sibling */ margin-right: -.25em; /* stretch line height */ height: 100vh; } .v-box{ display: inline-block; vertical-align: middle; white-space: normal; } .ud-dashboard { display: flex; min-height: 100vh; flex-direction: column; } .app { display: flex; min-height: 100vh; flex-direction: column; } .ud-footer { left: 0; right: 0; bottom: 0; }

This could be a component not being found, dashboard reset etc. @adam, i guess this is related to https://github.com/ironmansoftware/powershell-universal/issues/24 but i wanted to ask incase its just my setup.

@adam this also happens on the nightly for 1.3.1:

That’s a new one.

How do you reproduce this? Your session times out?

I either update a ps1 file in the background and that happens on my live site, or i restart the dashboard and it appears. For PSU i really dont know, but i have recreated it using IIS and msi installs. In the dark ages before PSU this used to have errors where the websocket was lost and it had connection errors, this error now appears like this… happy to have a screen share if you like.

I’m open to a screen share next week. Send me a DM with some availability and we can take a look together.

Will do, thanks. Just to confirm have you seen this on dashboards before? Or just not in PSU? I’m starting to get concerned it’s part of my deployment… I have had this error on pretty much all dashboards in all versions of PSU.

can you share the browser console when it happen?
@adam if all the components are loaded ok and let say he has a network problem this is what he need to see

Hi Alon,

Yes i can still browse and can use all the dashboard tools all fine, its just a display thing… I have just looked at the browser dev tools (network) and there are no errors, all 200’s.

My bigger concern tbh is this happening on my dashboards, when a component fails then i get this same error (as shown above), this again has no network errors showing in dev console, but does have ‘DevTools failed to load SourceMap: Could not parse content for https://URL/api/internal/javascript/index.2b1de2da85ef0e552e83.bundle.map: Unexpected token < in JSON at position 0’ errors

I cannot rule out network issues, but this is running in Azure on private VLANS, and i get the same errors on my dashboard and PSU when running VM to VM on the same subnet.

i see that a lot of js files are loaded from the cache can you clear your browser cache

Done, and still the same issues:

The plot thickens… I thought i would try and remove some dashboards (i have 4 running), when i remove one of them it all springs into life, then when i go to add it in again i get:


What happens next is the whole page crashes, and I cannot refresh (Crtl-F5) until i start a new browser tab and it then loads (without the new dashboard):

Added the dashboard back in again and i can no longer recreate the issue:

If i update the code on a ps1 file under /pages (which is a dot referenced page on the dashboard) i get the error again, but now when i stop the dashboard the error goes away, restart its also working but again, if i save a ps1 outside PSU it causes this error in PSU

Oh, that’s weird. I will try to reproduce that.

Happy to share if you want to see. It does seem strange that each save of a page restarts the dashboard, or at least tries too - this i think is causing issues because sometimes have VSCode set to to autosave. Is there any way i can turn PSU dashboard restart off for certain pages, so i control when the dashboard is stopped/started? Also i know this is a nice to have but a restart button would also be good rather than stop/start.

Thanks.

i have super spotty internet at the moment so a screen share probably won’t work. I’ll have a better connection starting tomorrow.

You can disable the auto-reload functionality by setting the -DisableAutoReload parameter in on the New-PSUDashboard cmdlet in dashboards.ps1 and maybe that would help. And I agree a restart would be a good button to add.

1 Like

There’s certainly something wrong with the auto-reload. I can’t get mine to work at all when editing in VS Code. It’s picking up the change and showing it in the web editor but the dashboard isn’t actually reloading for me.

Does this happen in new Microsoft Edge only? Have you tried IE or Chrome as a test?
If it only happens in new Edge browser, open new Incognito session and try loading PSU.
If the problem goes away in Incognito mode, you need to clear your browser cache for that page, see below.

Ignore 0 bytes, clear site data anyway

And remove cookies

Restart your browser.
If this didn’t help, you might need to reset your Edge browser from settings menu, but only if PSU works in incognito.

Oh and post a screenshot of errors in your console, this is what clean console should look like:

Thanks Raymix for the help,

I have cleared the cache, i didnt know you could do it by page so learnt something new right there! I do not get any errros in the console, i think there is a screenshot above somewhere. Its a strange one for sure but i believe the errors in PSU are related to updating in VSCode and the autoreload of the site in PSU. Since i have turned this off i am getting a much better experience.

I do want to ask though, if i do have a error on an endpoint, or i reset the dashboard this error comes up in the dashboard (not PSU), does anyone else see this? Im in the middle of migrating away from IIS with AD auth to AAD auth and docker and things are looking better so maybe my issues have been masked by this move.