Install component fails while running in container

i am experiencing unusual behavior with installing a component inside Powershell Universal 1.5.7 running inside a container:
I get : ‘Failed to save component. Error: Request failed with status code 405’
Then again, if i will refresh my screen and go to
i see

‘UniversalDashboard.ObjectTree 1.0.1 /root/.PowerShellUniversal/Dashboard/Components/UniversalDashboard.ObjectTree/1.0.1/UniversalDashboard.ObjectTree.psd1’

I can then enable it for a dashboard, and i can actually use it. So this error that pops out when i am installing it is misleading, can this be checked ? Why would this throw the error message if it actually gets installed ok ?

After this, i have installed PS Universal inside my local computer with windows 10, using choco, and i have done exactly the same steps, i have not received any error message, and it installed correctly. Could this be because its running in a container ?

Other example i don’t understand is in case component PowershellExplorer i get : Failed to save component. Error: Request failed with status code 400 , and still this component is not installed.
I tried to install the PowershellExplorer on it’s own inside my windows PS, and that worked ok, i saw that it returns Start-PowershellExplorer , and i could run it, so it looks like this is not a ‘single’ component but this is entire dashboard on its own, so is this more common that some components are ‘components’ and other are entire dashboards ? even if they are dashboards, can’t they be installed from marketplace website ?