PSU 2.8.0 components issue


i have downloaded the latest release 2.8.0 to test it out and found the following issue

  • hosting psu in IIS start fresh or upgrade same results

when starting fresh or upgrade if you login the first time to PSU and you create a fresh dashboard once you go to components you will see none added and you have the ability to add all which is good for fresh but it should not for upgrade. In earlier versions when you upgrade you will see what has been added before still in place

The issue that is affecting both fresh or upgrade is when you stop / start the apppool and you go back to components you will see that all of them went back to not added and the add button is grayed out even though testing the dashboard components are active there but still shows in components that they are not added and if you select one or all the add button still grayed out.

Product: PowerShell Universal
Version: 2.8.0

Tracking here:

Note that in 2.8, the embedded components (Charts, CodeEditor, UDStyle) are added to the PSModulePath so you won’t need to add those any more.

For example, I have a dashboard that uses UDStyle.

    New-UDPage -Id 'variables' -Name "Name" -Content {
        New-UDStyle -Style 'background-color: red' -Content {
            New-UDElement -Tag 'div' -Content {

UDStyle is not added.

But UDStyle still works.


This won’t work for components that aren’t included so it still warrants a fix.

Thank you adam for the verification its just one of these things that will make others confused, i was able to add my custom build component to the mix and removed -component from the dashboard file but it will be nice when you click on components to see that all of the built-in ones you have mentioned above shows as added so it will clear confusion since they are technically added automatically to the psmpdulepath instead of them shows as not added.

That’s a good point. I’ll make sure we get that resolved in 2.9.

In 3.0, we are merging the built-in components directly into the UD framework so there isn’t all this confusion around components. You’ll still be able to use custom components but all the built-in ones will just be in the UD module.

1 Like

I don’t know if this is related, but I upgraded this morning and am having issues with UDHelmet. It had been installed prior to this, but now I get an error that it can’t be found. I tried installing it through components, but nothing seems to happen with that.

It certainly could be the case. I’ve just run a nightly build that includes a fix for this issue. If you want to give that a shot, feel free.

Yes, that solved it. Thanks!

1 Like