Unable to load Components

Total rookie with Universal Dashboard and am kinda of fumbling through it but slowly learning things.

When I attempt to add a component from the marketplace I get a “Failed to save component. Error: Request failed with status code 400” error.

I’ve attempted to run my browser and Universal Dashboard as admin incase that was needed including powershell but still get the same error.


I’m just attempting to install this: https://marketplace.universaldashboard.io/Dashboard/ud-activedirectory to play around with it.

Seems like a bug. That’s a dashboard example and not an actual component so we probably shouldn’t be showing that in the marketplace within the UI.

If you want an AD example, you can go here: https://github.com/ironmansoftware/universal-templates/tree/master/active-directory

It won’t install automatically but you can just grab the code and go. I also have a blog series on how each of the features of that dashboard work: https://ironmansoftware.com/active-directory-help-desk-restore-deleted-users/

Hey @Ranger welcome to the community! I got a few blogs on loading custom components on my blog page:- https://psdevuk.github.io/ud-flix/ it’s no-where as in-depth as the official documentation here:- https://docs.universaldashboard.io/ I hope these links serve you well :+1:

Sorry to bump this old topic, but I am getting this error when trying to download UDSelector on PSU 1.5

Failed to save component. Error: Request failed with status code 400

Is there somewhere on the filesystem I can just place the module in for PSU to recognise it?

If it is downloading from the Powershell Gallery I have to run:-

[Net.ServicePointManager]::SecurityProtocol = [Net.SecurityProtocolType]::Tls12

to allow me to download stuff from powershell gallery whilst at work…

Ok I have found a way around this, in-case anyone else gets this, I copied the module to:-
C:\Program Files (x86)\Universal\UniversalDashboard\Components
Then restarted the powershell universal service, I can now see the component registered in PSU