Getting a gray page instead of a dashboard

New web server setup, and i’m seeing this issue where the dashboard is blank. When i look in the pud logs I see an unhandled exception error. And in the IIS logs i see a 500 error


[Info] Microsoft.AspNetCore.Mvc.Internal.ControllerActionInvoker Executed action UniversalDashboard.Controllers.DashboardController.Index (UniversalDashboard) in 16.203ms
[Error] Microsoft.AspNetCore.Server.Kestrel Connection id “0HM0D7P24LUCC”, Request id “0HM0D7P24LUCC:00000003”: An unhandled exception was thrown by the application.
[Info] Microsoft.AspNetCore.Hosting.Internal.WebHost Request finished in 68.9938ms 500


020-06-10 13:00:39 REDACTED GET /api/internal/dashboard - 80 - REDACTED Mozilla/5.0+(Windows+NT+10.0;+Win64;+x64)+AppleWebKit/537.36+(KHTML,+like+Gecko)+Chrome/83.0.4103.97+Safari/537.36 http://REDACTED/mystaff 500 0 0 139

Any idea what i should check?

Any way you can send me the full logs or dashboard?

Will do, what is the best way to get you a zip file?

Just email me at adam[at]

thx, i’m reinstalling iis just to make sure i didn’t mess something up (that i’m aware of). I don’t think it’s the dashboard code as it works on a partner server. It’s probably something with IIS or the .net core hosting package.

I’ll send the code along + my logs after the reinstallation.

1 Like

Hi, @adam I can start PUD without IIS. And while some of the functionality built on an assumption of IIS doesn’t work, the app its self does work. So this is probably something related to IIS <–> to PUD.

I’ve completely uninstalled IIS, and reinstalled. Then completely uninstalled all of the .netcore 2.x stuff and reinstalled (Plus rebooted). Anything else i should check?

I was digging through the logs and didn’t notice anything off. Can you just check in your browser when you load up that page and press F12 and look in the console there? There might be some sort of hint as to what is going on from a client perspective. The fact that it loads the client assets but can’t load the dashboard is a bit strange.

Almost everyone in this community hosted in IIS and it works flawlessly, you need to do the following

A- If you ever uninstall IIS and re install you need to reinstall .net core hosting bundle.
B- make sure to unblock the universal dashboard files as follows
gci -path ‘UD files location’ -recurse | unblock-file
C- check your web.config file and make sure that you are using modules=“AspNetCoreModuleV2”
D- always start with very simple basic dashboard to make sure UD is actually working in IIS
E- whenever you need to update UD you need to remove all previuews files and just keep your dashboard.ps1 & web.config files and copy over all files from new release (dont use copy and replace)

1 Like


I’ve completely uninstalled and reinstalled IIS, leaving the defaults. I then uninstalled all .netcore 2.x component and reinstalled them and rebooted.

I just tried unblocking + your modules trick, still no luck.

With my client tools in chrome, it shows the same 500 error that the IIS logs do.

I install the PS module to all users “-scope allusers” via PS. I’m not downloading / copying the module.

The dashboard starts up fine without IIS. Which is why i think it’s something between IIS and PUD. Not sure what per se, but something there.

To be clear, I’m not saying this is a PUD issue. I’m sure it’s something related to IIS / .net core, i just don’t know what. I don’t know if it’s some simple setting i’m missing in IIS or something like that. My luck is that’s exactly what it is.

ok… so brand new dashboard (hello world type). and that works. No IIS auth or anything like that. I’ll add more and more and see if i can figure it out. Thanks for the tip.

ok fixed, man am i a dumby :slight_smile:

So it turns out when setting up my site, i forgot to enable Windows auth. I had it installed, but never enabled.

I was able to figure this out by using the simple hello world script and when i added the login page it stopped working.

am glad you were able to figure out the issue, starting simple always pays out at the end the main issue is most of the time in IIS or UD you get generic errors and its very hard to determine the root cause so its best to start with simple dashboard and proceed from there.