No Content Using IIS - Just A Blank Page

Trying to run a simple dashboard but just getting a blank white page and no errors in sight.

  • main and vendor .js files are loading fine (no 404)
  • IIS site is running from D:\wwwroot\
  • IIS App Pool is running as LocalSystem
  • .NET 4.7.2 is installed
  • .NET Core Hosting Bundle 2.1.5 is installed
  • Universal Dashboard 2.5.3
  • PowerShell 5.1.14393.3053
  • No errors in Event Logs
  • No errors in D:\logs\weblogs.txt
12:21:25 [Info] Microsoft.AspNetCore.Hosting.Internal.WebHost Request starting HTTP/1.1 GET http://itdash.***.local/  
12:21:25 [Info] Microsoft.AspNetCore.Hosting.Internal.WebHost Request finished in 5.2169ms 200 text/html; charset=utf-8
  • dashbard.ps1:
$Dashboard = New-UDDashboard -Title "Hello, World!" -Content {
    New-UDHeading -Text "Hello, World!"
Enable-UDLogging -FilePath "D:\logs\weblogs.txt"
Start-UDDashboard -Wait -Dashboard $Dashboard

Resolved - guess it does nothing on IE, works fine in Chrome.

Took a day to get running after fighting other errors. Documentation could use an update as it appears to be based on an older version of UD.

Hi @CrookedJ was just replying to another post and was going to make this one next…Glad you have this solved…Although seems weird that only working in Chrome, as I have a dashboard running at work on my windows 10 PC using IIS and as users are remote desktop only have IE I am forced to use that, and my dashboards work fine.
Sometimes clearing cache can help, or starting stopping the site. More than happy to help you investigate this further if you want but just to let you know it should work in IE.

If you could open the dev tools in IE (F12), you should be able to see if there is an error present. It could be a single control that is causing some weird IE issue.

In terms of IIS hosting, I’m looking to improve that experience. This type of question comes up a lot and I’d rather that it just worked than relying on documenting the correct rain dance you need to perform to get IIS working:

If there are particular documentation items that you found out of date, please let me know. We try to keep the documentation up to date but it’s easy to miss stuff.

Hey thanks for the replies, what tipped me off was the fact that I could get to it remotely (but got the message about not being able to view dashboards remotely in the trial). So I went ahead and installed Chrome and tried that.
It is IE11 on Server 2016. No errors in Console or Network.

EDIT: Could very well be some group policies at play that are causing the issue.

I’ll definitely give some feedback on the documentation as I will most likely be running through this setup again on another box soon.