Different behavior of GET-PSDRIVE in Powershell and in Dashboard

2 weeks ago I begun to develop a small application to manage a crypto farm and this is the first time I came in deeper contact with powershell and with the universal extensions. I come from c++, so everything is a little strange but I love it and the dashboard is great.
I run into several smaller problems and I hope I can get some help here while finishing the application in the next time.
So, one of my problems is the behavior of GET-PSDRIVE in the dashboard. If I run it in Powershell I get all drives, including the network drives. If I run it in the dashboard I only get the local drives. The network drives were manually mapped in the explorer.
I think the mapping is done in another user context and that causes the problem.
Has anybody an idea how I can solve it, I prefer that the user can map the drives in the explorer because I need no other interface.


This has to do with how you’re hosting PSU. If it’s running as a service, it’s always going to run in a different context and not have access to those mapped drives.

New-PSDrive always maps to the current users profile. You can either map the drives in the system scope or run PSU under the context of the local user account.