HELP! PS Universal Dashboard Script can not access to drive network mapped!

Product: PowerShell Universal
Version: 3.0.6

Hello evrery one,

I’m trying to create dashboards to monitor my app server.
On that app server, I have logs updated per minute.
On another server which is running PS Universal Dashboard, I have tried to map network drive from the app server with a credential.
I tried to access those data from that drive with scripts on PS Universal Dashboard.

$logCountMessageMinutes = “F:\CountMessageMinutes” + (Get-Date -Format “ddMMyyyy”) + “.csv”
if (Test-Path -Path $logCountMessageMinutes) {

  • $DynamicData = Import-Csv $logCountMessageMinutes | Select-Object -Last 10*
    New-UDTable -Data $DynamicData -Title “Powershell Message Tracking”

But it can not access those data.

I guess that my PS Universal Dashboard is running as Local system so it cause this problem!!!
Am I right or wrong?

Please help me with this problem!!!
Thanks a lot!

if your PSU running as local system you need to add the computer account of the PSU in the administrators group of the app server in order for the app server to allow access from PSU.

1 Like

@wsl2001 Thanks for your response!
But there’s one more problem I did not mention before that the app server and the PSU server are not in the same domain.
The PSU server joined our organization domain while the app server is not.
So I can not add the PSU computer account to administrator group in the app server.

you might need to try this

1 Like

@wsl2001 Thank you for your recomendation!
I will research the New-PSDrive cmdlet!
I have just changed the way to get logs from the app servers!