Dashboards Won't Start - "Dashboard process is not running. Dashboard may have crashed or failed to start."

Product: PowerShell Universal
Version: 2.2.1
Environment: Docker on Windows - Running as a Linux Container

I am trying to get PowerShell Universal running locally to do some dashboard development work before hosting on another instance (which will also be running as docker container).

I am able to start the container and access PowerShell Universal and login, however when I create a dashboard it never starts and I get the following error:

fail: Universal.Server.Services.DashboardManager[0]
      Dashboard process is not running. Dashboard may have crashed or failed to start.

I’m not sure if it is related however I also get this error on starting the container:

fail: UniversalAutomation.StartupService[0]
      Failure configuring Universal. Some settings from your configuration files may not be applied.
      System.IO.DirectoryNotFoundException: Could not find a part of the path '/root/.PowerShellUniversal/Repository/pages'.
         at System.IO.Enumeration.FileSystemEnumerator`1.CreateDirectoryHandle(String path, Boolean ignoreNotFound)
         at System.IO.Enumeration.FileSystemEnumerator`1.Init()
         at System.IO.Enumeration.FileSystemEnumerable`1..ctor(String directory, FindTransform transform, EnumerationOptions options, Boolean isNormalized)
         at System.IO.Enumeration.FileSystemEnumerableFactory.UserFiles(String directory, String expression, EnumerationOptions options)
         at System.IO.Directory.InternalEnumeratePaths(String path, String searchPattern, SearchTarget searchTarget, EnumerationOptions options)
         at UniversalAutomation.Services.PagesConfigurationScript.ReadAsync(Boolean initialSync) in D:\a\universal\universal\src\UniversalAutomation\Services\Configuration\Pages.cs:line 50
         at UniversalAutomation.Services.UniversalConfigurationService.Read[T](Boolean initialSync) in D:\a\universal\universal\src\UniversalAutomation\Services\UniversalConfigurationService.cs:line 266
         at UniversalAutomation.Services.UniversalConfigurationService.SyncAsync(Boolean initialSync) in D:\a\universal\universal\src\UniversalAutomation\Services\UniversalConfigurationService.cs:line 248
         at UniversalAutomation.StartupService.StartAsync(CancellationToken cancellationToken) in D:\a\universal\universal\src\Universal.Server\Services\StartupService.cs:line 70

In the past with older versions I don’t recall having these issues. Has anyone else run into this, I haven’t been able to find much regarding that specific error related to dashboards.

I tried this using Docker on an Linux Machine and also had the same error. Wondering if the current container image for 2.2.1 has a bug in it potentially?

Update: I went through the process of doing a manual install and run on Linux and that works. This appears to be something related to the ironmansoftware/universal Docker image.

It does look like an issue. I’ve just got another report of this happening for someone else. I’ll look at getting it resolved for 2.3.0: Issue with Docker image and dashboards · Issue #361 · ironmansoftware/issues · GitHub

I’ve been able to reproduce this. One thing to note is that if you use the Integrated environment rather than the Default or 7.0.6 environment, the dashboard successfully starts.

I was receiving an HTTP 500 Error: Unexpected end of JSON input using the 2.2.1 container. Manually setting the environment to integrated did the trick. Thank you Adam.

1 Like