Cant start dashboard from Visual Code =====> PowerShell Integrated Console <=====

Hi there,

I cant seem to start a dashboard form visual code.
I get the error:
Application startup exception: System.MissingMethodException: Method not found: ‘Microsoft.Extensions.Logging.ILoggerFactory NLog.Extensions.Logging.ConfigureExtensions.AddNLog(Microsoft.Extensions.Logging.ILoggerFactory)’.
at UniversalDashboard.ServerStartup.Configure(IApplicationBuilder app, IHostingEnvironment env, ILoggerFactory loggerFactory, IApplicationLifetime lifetime)
— End of stack trace from previous location where exception was thrown —
at System.Runtime.ExceptionServices.ExceptionDispatchInfo.Throw()
at Microsoft.AspNetCore.Hosting.ConventionBasedStartup.Configure(IApplicationBuilder app)
at Microsoft.AspNetCore.Hosting.Internal.WebHost.BuildApplication()

I am using the preview powershell extentions (beacuse is has psreadline support)

I can start it from a regular powershell console

Any idea’s?

I have the same problem.

This sounds like we have some conflicting assemblies loaded into the PowerShell Integrated Console. Could you please open a GitHub issue for this?

I’m seeing the same starting today, I can’t run my dashboard at all.

Rolling back the PowerShell extension in VS Code to 2020.1.0 resolved the issue. It seems 2020.3.0 has a problem.


Yes, rolling back to 2020.1.0 for the PowerShell extension worked for me.

1 Like

This worked for me too. Thanks.

Same issue, same fix. Dash is working launched from Visual Studio Code with PowerShell Extension 2020.1.0 but Microsoft.Extensions.Logging.ILoggerFactory error with version 2020.3.0

I am using Powershell 7 and 7.1 Preview 1 in vscode and UniversalDashboard 2.9.0 (Not the community version) without any problems.
What Powershell version and UniversalDashboard Edition are you using?

Powershell Extension:

Version: 1.44.1 (user setup)
Commit: a9f8623ec050e5f0b44cc8ce8204a1455884749f
Date: 2020-04-11T01:48:12.622Z
Electron: 7.1.11
Chrome: 78.0.3904.130
Node.js: 12.8.1
OS: Windows_NT x64 10.0.18363



Same issue here on v2020.6.0

I know this is a dated post, however I had the same issue. I solved it by opening a new powershell terminal within VSCode and using that one, it allowed the dashboard to work without having to roll anything back.