AD Authentication Errors

Hoping for some support.

I recently upgraded my install from 1.3.1 to 1.3.2, using the MSI method. The upgrade seemed to hose everything completely. Services wouldn’t start, errors about PS1 files missing. I restored my VM and instead went to the 9/30 build of version 1.4. This upgrade went smoother. I played with the new features and interface. Restarted the server a couple times to make sure it came online after.

This morning I sit down to start my day and try to log in to the interface but am met with a bad password message. A few retries, same thing. Logging in with the local account works fine. I also verified that it is using the right config file because I modified the “Admin” username to something different, and that auth works fine.

The errors I see in the log are:

CORS policy execution failed. (09b6f179)
Authorization failed. (b15dd539)

Hey @dolinger

Apologies for the issue. This issue was actually known and the fix never made it into our production build through a mistake on my part. We are currently deploying a 1.4.1 to production and it will be available in the next 30 minutes or so.

Very embarrassing to have this one sneak through. Sorry about that.

Thanks, Adam. I restored my VM back so it is back up on an older version. Once I see the 1.4.1 release I will give that a shot.

I grabbed the latest MSI, it still had 1.4.0 for the filename, but the filesize was different than the previous 1.4.0 file I had.

I restored my VM back to the 1.3.1 install and upgraded to 1.4.1, but I am still seeing the same issue and the same messages in the log.

Can you try this link?

It shouldn’t have the 1.4.0 file name.

That seems to have resolved the login issue.

But I am unable to browse to the Settings area, the menu option isn’t available. Browsing to the Settings from my browser history says the page isn’t available. This is when I log into UD with the local admin or my AD auth.

It sounds a bit like the authorization policies aren’t evaluating correctly. I take it you are using something similar to the example in our docs?

Can you please enable debug logging? In the appsettings.json file, you’ll want to set the default value to Debug.

  "Logging": {
      "LogLevel": {
      "Default": "Debug",
      "Microsoft": "Warning",
      "Microsoft.Hosting.Lifetime": "Information"

Then please reproduce this issue and send me the log. That should help me diagnosis.

I didn’t see an attach option so I uploaded to PasteBin. This is just the start of the DBG lines.

1 Like

Hi @dolinger,

Thanks for the log. Unfortunately, I’m not seeing anything standing out that would cause this to happen.

If you have a chance to try the 1.4.2 nightly build that would be very helpful as I’ve added some more logging to try and diagnosis this error:

I’ll continue to try and reproduce.

The 1.4.2 nightly has brought back the Settings node. Very weird.