Problems logging in, version 1.1.1


I have downloaded the Powershell universal and the installer starts the login page in my browser. But I can´t login. In the console window, the following occurs:

I tried to login ad Admin using “any” password, but also the password “any”.

The problem may be related to the other errors that occurred earlier:
fail: Universal.Server.Services.DashboardAssetManager[0]
The specified RequiredModules entry ‘Universal’ in the module manifest ‘C:\Program Files (x86)\Universal\UniversalDashboard\Frameworks\v2\UniversalDashboard.psd1’ is invalid. Try again after updating this entry with valid values.

Does anyone know what the problem is?


Hey Peter,

Can you let me know which versions of PowerShell you have on your machine? It looks like one of the PS processes is failing to initialize properly.

Hello Adam,

I have the following versions:

I noticed that I had UniversalDashboard.Community v2.9.0 installed. After uninstalling that, the only error that remains is:
fail: Universal.Server.Services.SecurityProxy[0] Failed to authenticate user. Grpc.Core.RpcException: Status(StatusCode=Unavailable, Detail="failed to connect to all addresses") at Universal.Server.Services.SecurityProxy.AuthenticateAsync(String userName, String password) in E:\src\universal\src\Universal.Server\Services\SecurityProxy.cs:line 84


Hey Peter,

We currently have a problem with PowerShell v6 where it’s failing to load some stuff. I think that’s likely your issue. In the next version you’ll also be able to select the default version so that when it starts up you don’t run into this problem.

The only current work around for 1.1.1 is to install PS7 and uninstall PS6.

1.2 should be out sometime next week if you’d like to wait for a proper fix.


Hi Adam,

I upgraded to Powershell 7.0.1 and now it works. I had to uninstall, clean some directories and then reinstall.

Thanks for the help


Having same issue. I’ll see if @grtswt method will work for me. Also I don’t have a clue what account and password to use for admin login. Second thought, I think that I’ll just wait for version 1.2 and try again.

Hopefully, the new version will prompt for credential creation during the install process.


The default admin is just “Admin” with any password. We won’t have a prompt for default creds in 1.2 but I’ll put that in the backlog to add for 1.3.

v1.2 should be out in the next couple of days.

1 Like

Thanks, Adam.

C:\Program Files (x86)\Universal\Universal.Server.exe --service

Also, it would be nice to have the option of installing this service in any desired location if that is at all feasible to do. Maybe just weirdness on my part but MS always seems to treat the ‘Program Files’ folders differently and I’ve just grown to avoid putting anything in these folders that are not an MS product.

Thanks again. Looking forward to 1.2