1.2 Version Feedback

Installed 1.2 this morning few issues/suggestions:

  1. Document the upgrade process, do we just install the old over the top or do we need to stop the service manually, uninstall old at all first? I had some issues personally and ended up manually deleting the folder under C:\program files(x86) and then reinstalling 1.2 version again.

  2. In 1.1.1 when I added a script I could specify the path to the script, that is gone in 1.2 and forces the script to be under the repository directory in “C:\ProgramData” - this is not ideal as I was storing it under a different folder for source control purposes.

  3. Once I installed 1.2 I did not have any way to modify the framework it was using. I had to delete the dashboard and add it back to set the new framework version.

  4. It seems “auto-reload” is no longer something you can toggle on and off.

  5. Some how the “edit” feature managed to wipe out my script at one point which wasn’t good. Luckily I had a backup. Something about the transition from 1.1 > 1.2 and clicking the “edit” button.

  6. Biggest issue that I may open a github issue on - the dashboard keeps timing out for no good reason now. Page loads, about 30 seconds-60 seconds later I get “Your session has timed out - Refresh the Page”. I can’t use it right now at all really - luckily this isn’t in production yet.

Here is from browser console:

A couple questions:

1.Is custom CSS available in anyway or planned with the current 1.2 release? I relied pretty heavily on it for my form design in the earlier version of v3. After the upgrade I’m having issues with my buttons going off the “New-UDPages”

  1. Is there a way to get code completion with universal? Since it is no longer installed as a conventional module I’m not getting good code completion. I tried running Import-Module "C:\Program Files (x86)\Universal\UniversalDashboard\Frameworks\v3\UniversalDashboard.MaterialUI.psm1" but that doesn’t seem to work like it did before. The commands are valid now but I’m not getting any tab completion.

Thanks for all the feedback.

  1. We can document it but it should have just worked. It sounds like a bug with the installer.

  2. I’ll take a look. You should be able to put the script where ever.

  3. We can add something to the UI for this. You should be able to manually edit the dashboards.ps1 file and update the framework version.

  4. This is a system-wide setting now. Check out settings.ps1 and set the -DisableAutoReload parameter. I think making this more granular will be a good idea.

  5. This has been mentioned and we are actively looking at it. Nasty one.

  6. I haven’t seen this one but I will look at that today. If I can’t reproduce, I’ll likely request some more info from you.

  7. Custom CSS is planned. With the change in how themes work it’s not really possible at the moment. You should be able to use UDStyle but I haven’t actually tried it myself.

  8. You can install the modules from the gallery so you have IntelliSense - They are just Universal and UniversalDashboard

I can confirm number 6. Was seeing the same thing yesterday. Dunno if related, but I was also having issues with page loads. If I clicked a page in my appbar, it would load to blank screen. I would have to hit refresh once or twice to get the page to load up.

1 Like

Yeah also saw the same with 2 & 6.

  1. is it me or is there no delete button once you’ve added an identity?
  2. Found that if you hide automation in the settings (from the menu), next time you login, even though its not there, you’ll still land on the ‘scripts’ page.

FYI for the timeout issue, I’m hosing mine in IIS (idle timeout is set to zero - also tried tweaking connection time out just in case)

I’ve found the source of 6. It’s effectively restarting the dashboard every 60 seconds and that’s why the session is timing out. A fix will be in tonight’s nightly.

  1. I’ve added this to our backlog. Missed that one.
  2. I’ll add this too. Hadn’t noticed that one.
1 Like

is 6 (session timeout resolved) I still see this every 60 seconds or so on 1.2.6

I’m not experiencing this any more. My sessions don’t expire after 60 seconds and the process isn’t restarting. Can you upload a log with the behavior happening?

fixed it by uninstalling, then deleting
C:\Program Files (x86)\Universal
reinstall latest build.

then no timeout issues! :slight_smile:

1 Like