Vscode module PSU how trust self signed cert?

Hi,
I have a self signed cert for https on my developer server and the vscode module are complaining.
How can I bypass this? I can’t connect to the server because of this.

Failed to query configuration files. unable to verify the first certificate This is a connection error.

I seem to be able to recreate the issue.

image

My next step was to add the cert to the user trusted certification authority. This changed the error to the more generic one below. This is where I’m stuck.

Failed to connect to PowerShell Universal. Universal may not be running or you need to update your settings.

image

I added the .pfx certificate to quite a few stores (both user & machine) but it does not make a difference.

@adam can you advise if it is possible to connect to PWU on https with the VS Code extension?

1 Like

I don’t know why that isn’t working. We use the axios library to query the web service which certainly supports HTTPS. Feel free to raise an issue for it and I can look into it. There is likely a setting we can set to avoid certificate errors but it probably wants valid certificates by default.

I have done that :slight_smile:

2 Likes

Sweet! I’ve updated the VS Code extension to support this as well as multiple connections.

1 Like

Perfect, thanks

The issue are still there, I was just trying it out.

Do you have the cert installed in trusted root? We aren’t ignoring certificate errors so if it’s not trusted you will see an error like this.