Having an issue connecting to PSU with VSCode

Product: PowerShell Universal
Version: 3.8.12

Since 3.8.12 I am getting an error “unable to get local issuer certificate” when connecting via VSCode. My 2.x instance is still working. I have tried creating a new token, however the issue is persistent.


I am using an internal CA for this instance, and my other instance is using Let’s Encrypt… however the CA is trusted and loads fine in the browser. Changes to allowInvalidCertificate also have no effect.

Does your 3.x environment use the same underlying infrastructure?

I currently have the same problem and have traced the problem to how my Azure app gateway handles the data. This is something I still need to figure out.

I am running on-prem, no proxy for me. This issue is persisting in 3.9.1

This issue seems to be related to the VSCode version.

I am having the exact same error messages as the screenshot in the first post.
I have two local instances of PSU, one is version 2.15.5, and one is 3.7.12.
I am receiving the same error when connecting to any of the instances.

On one machine running VSCode 1.76.1, the extension connects fine to my instances.
On my other machine recently updated to VSCode 1.78.0, it does not work.

I then upgraded VSCode 1.76.1 to 1.78.0, and then the addon broke. I’m staying on 1.76.1 for now.

The about box on the working VSCode, says the following:
Version: 1.76.1 (user setup)
Commit: 5e805b79fcb6ba4c2d23712967df89a089da575b
Date: 2023-03-08T16:32:00.131Z
Electron: 19.1.11
Chromium: 102.0.5005.196
Node.js: 16.14.2
OS: Windows_NT x64 10.0.19045
Sandboxed: No

The same aboutbox after upgrading says the following:

Version: 1.78.1 (user setup)
Commit: 6a995c4f4cc2ced6e3237749973982e751cb0bf9
Date: 2023-05-04T09:48:08.683Z
Electron: 22.5.1
Chromium: 108.0.5359.215
Node.js: 16.17.1
OS: Windows_NT x64 10.0.19045
Sandboxed: No

Here’s the issue to track this: unable to get local issuer certificate error in PSU VS Code Extension · Issue #2394 · ironmansoftware/issues · GitHub

It does look like Microsoft upgraded NodeJS versions for VS Code in the April update. I have to imagine that was the cause of this but I haven’t been able to identify exactly why.

Can you verify that you have this setting enabled in VS Code?

Version 1.77.3 seems to resolve the issue for me. You’ll need to turn off automatic updates in VSCode, then you can install 1.77.3 right over the top without uninstalling.

This was fixed in VSCode 1.78.2, see Cannot find module 'vscode-windows-ca-certs' · Issue #181404 · microsoft/vscode · GitHub