Valid JobHandshakeTimeout

Product: PowerShell Universal
Version: 4.2.12

I have been receiving some errors with automated scripts. The message is always the same:

Error executing job: PowerShell did not respond in a timely fashion. PowerShell Universal is currently waiting 5 seconds for PowerShell to start running the script.
You can increase the timeout by setting the 'Job Handshake Timeout' setting in the Settings \ General \ Automation page.
If you are still experiencing issues, you may need to consider increasing the resources available on your system or take advantage of the Random Delay parameter for schedules to stagger jobs.

I have had some success with staggering the start times, but I am still running into a fair amount of these errors. All schedules already have the -RandomDelay parameter. The Job Handshake Timeout is currently set to 120. I was just wondering what a recommended timeout would be, or if there is another way to get these errors taken care of.