V3-beta7 - New-UDTable output

And moving on…

I’m trying to output to New-UDtable with a New-UDSelect so that my users can change the option on-the-fly from what is loaded. What I’m finding is that very randomly, the select dropdown will not appear in the table/grid. Its coming back with a 404 Not found.

Here is my code:
New-UDTableColumn -Property “HireReason” -Title “Hire” -Render {
$HRItem = ConvertFrom-Json $Body
$Cache:TheItem = ConvertFrom-Json Body New-UDSelect -Id "sel($HRItem.EID)" -DefaultValue $HRItem.“HireReason” -Option {
New-UDSelectOption -Name “New Hire” -Value “New Hire”
New-UDSelectOption -Name “Rehire” -Value “Rehire”
New-UDSelectOption -Name “Update” -Value “Update”

Here is a screenshot of the 404s:

Its completely random. One time through I’ll see two of them, next time, 3, sometimes 4. Rarely all 5 will show up. I’ve tried it with and without setting an Id, I’ve tried $HRItem = $Body | ConvertFrom-Json

I also tried just using a button with the code from the AD Helpdesk example, and it does the same thing.

Might be a bug, but just wanted to check before I throw it out as an issue.