Updated to 1.1.1 now UA doesnt load

Hi Everyone,

Uninstalled all the old modules and installed the new ones, went from 1.0.1 to 1.1.1 and now the UA doesnt load… First when running the commands

Install-Module UniversalAutomation -Scope AllUsers -AllowPrerelease
Install-Module UniversalAutomation.Dashboard -Scope AllUsers -AllowPrerelease

Dashboard fails and says commands already exist and to add the -AddClobber switch… Did that, haven’t seen that before… Then When i go to launch the UA Dashboard it fails to load. Looking at the logs.

New-UADashboard : The term 'New-UADashboard' is not recognized as the name of 
a cmdlet, function, script file, or operable program. Check the spelling of 
the name, or if a path was included, verify that the path is correct and try 

This is all running within IIS, When I open Powershell manually and verify both modules are installed, and if i run New-UADashboard manually I get the same error that the command doesnt exist. I didn’t see any Bug reports on Github, so maybe I am doing something wrong? Any ideas would be great! :slight_smile:

Hey @Obie,

This was a mistake on our part. When we rebuilt the dashboard for 1.1 we implemented Start-UADashboard and didn’t port over New-UADashboard. Double-fail.

You should be able to replace your call to New-UADashboard + Start-UDDashboard with just a call to Start-UADashboard.

I promise we won’t introduce a breaking change like this without proper documentation and\or migration paths again.

Hey @adam

Makes sense! Now you dont have the requirement for the UD Module… So I replaced my commands

$Dashboard = New-UADashboard -ComputerName http://itauto:8080
Start-UDDashboard -Dashboard $Dashboard -Wait 

Start-UADashboard -ComputerName http://itauto:8080 -Wait

So now it at least begins to start up. Then i get the Trail of UD Error… I put the LIC file in the net472 folder but still get the error.
C:\Program Files\WindowsPowerShell\Modules\UniversalAutomation.Dashboard\1.1.1\UniversalDashboard\UniversalDashboard.Enterprise\net472

Then I get this error

Im guessing it has to go with the lines above? I tried -Port 8080 in the Start-UA but it didn’t load that way either and got the same error.

Does this mean we don’t need the 2 IIS Sites anymore and it almost should run all on one? Like a UniversalDashboard?

Thanks :slight_smile:

It still needs two sites because it’s 2 web servers at the moment.

Can you try this?

$Env:UDLICENSE = "<myLicense here>"
Start-UADashboard -ComputerName http://itauto:8080 -Wait

The Page not loading thing in the background fixed itself somehow… but the License still has an issue…

Remote access not allowed when unlicensed.

Trail of UD in the corner.

For the UDLICENSE i put the whole thing in the file starting with <License><Terms>