Trying to get UA going

I am trying to get AU up and running and getting a error popup.

Here is what I am running in PowerShell.

Import-Module "UniversalAutomation.psd1"
Import-Module "UniversalAutomation.Dashboard.psd1"

Start-UAServer -Port 10000
Connect-UAServer -ComputerName "http://localhost:10000"

$Dashboard = New-UADashboard
Start-UDDashboard -Dashboard $Dashboard -Port 10001

I get an error specifically on Start-UAServer -Port 10000.


Any and all help is appreciated. Is this the proper script to use for running UA in IIS?

I may have answered my own question.

If I run the above in PowerShell, not the ISE, it works as intended. I am a UD/UA novice, would I just need to save this as a script and point the IIS site to it?

I dont see any official documentation regarding UA with IIS, so I am using the UD IIS docs.

I just opened an issue for the ISE. I hadn’t tried UA in the ISE before. We will get that fixed.

As for IIS, I’ll make sure to update the UA docs before we GA but the hosting will be the same as the UD docs for hosting it. I’m not 100% sure how to configure the UA\UD site in the same IIS WebSite. You might need to stand up 2 websites. One for UA and one for UD. This would mean 2 ps1 files as well. I’ll have to work on this type of configure and write up some official docs.

Here’s some documentation on IIS hosting:

I got that working but had to make some tweaks to UA so that the AppPool user could access the folders correctly. I added a -RepositoryPath parameter to Start-UAServer to allow for configuraiton of where that’s stored. That will be out in the next release.

If you mess with the permissions, I think you can get it to go on the current version.