UD-Markdown - Component Not Registered

The markdown module was working fine for me until recently and now every time I try to use it I get the error “Component not registered: UD-Markdown”

I’m doing the same for the markdown module as I am for all other modules I’m using (about 20 of them) and putting the module path in New-UDEndpointInitialization -Module @()

I’ve also tried reinstalling the module and specifying import-module right before I use the New-UDMarkdown command but nothing seems to work. There doesn’t seem to be anything specific to the markdown module in the UDLog file other than:

[Info] Microsoft.AspNetCore.Hosting.Internal.WebHost Request starting HTTP/1.1 GET http://localhost:10000/UniversalDashboard.Markdown.c10d4f82b28de42c2ac2.bundle.js

Has anyone else come across this type of error when using imported modules?

Strange, I tried building a new VM, fresh install of UD and all the modules pulled down from the powershellgallery and I get the same issue on this VM too!

I’ve also tried a new test dashboard with just one card and a New-UDMarkdown as the content but the same issue happens.

Is anyone else experiencing this?

Are there any errors in the browser console?

Hey Adam, there is actually:

@AlonGvili might have an idea.

This looks like an issue that was brought up a couple months ago: https://github.com/AlonGvili/UniversalDashboard.Markdown/issues/6

Ah yes looks the same as that. I’ve just tried in Chrome (don’t know why I didn’t try that earlier!) and it does work. I get the error in edge and IE.

@AlonGvili do you know what sort of timeframe we’re looking at for a fix to this? We’re looking to release the next version of our webapp soon which uses udmarkdown so I might have to re-write all of the markdown sections to UDHeading and UDParagraphs (which will be enormously time consuming!)

sorry for the late response, I’m re-writing the module, I hope in a day or 2 I’ll finish it

1 Like

Amazing, thank you so much, that will save me days of work!

ie 11 and ms edge

i will upload the new version into psgallery today

1 Like

Hey @AlonGvili, thanks so much for rebuilding this. I do seem to be having an issue with it though:

Any idea what this might be?

I get the same whether it’s markdown that I’ve got using Get-Content or whether I put the markdown in quotes directly in the command.

Yea i knew i forget to update something, untill I fix it in the styles parameter create this

Styles @{
table =@{
thead ={

tbody =@{
trow =@{}


You can see from the source code all the nested children’s

No worries, it seemed to get rid of the thead error but I now get another :laughing:
I tried putting trow in the styles, table and thead hashtables but I couldn’t get it to work. Do you know what format it needs to be in and if there are any other properties that need adding?

I edited the comment above

Excellent thank you!
I did this in the end and it’s working now:

-Styles @{
tbody =@{
trow =@{

I will fix it in the next couple of days , just need to find the time for it