Silly Question Regarding Hosting UD Sites Internally

Hi all,

Forgive me as I haven’t seen this information anywhere else, an I’ve been searching all morning…

How does one use the community edition over the network? Whenever I try, it prompts me to buy a license. The thing is that my manager needs to see this in action before he’ll commit to purchasing a license (or multiple licenses because I believe it is $100 per dashboard). What is the best way to run a UD website in a Windows environment so that others can access it too? Do you just execute the PS script on each computer and share the scripts with each other and generate a local instance instead of a link to the hosted dashboard? I am hoping to demo a few dashboards for the higher-ups at some point, and was wondering what the best way to do that is?

I have a Winform GUI that I built that has tons of buttons and features, and I was thinking of converting that into a universal dashboard. I also have a reporting dashboard that I wrote in Winforms that uses SQL queries to populate it and that would also be a great candidate to create a useful dashboard from.

I just don’t know how to approach the issue correctly.

I’m in the same situation and I did the following:
On my server I used Publish-UDDashboard ( to run my dashboard.
I configured it to only listen to the address (Start-UDDashboard -ListenAddress
I then installed ARR and UrlRewrite on my IIS server, created an application (No managed code) with only a web.config with this content:

     <rule name="api" stopProcessing="false">
      <match url="(.*)" />
      <action type="Rewrite" url="http://localhost:10101/api/{R:1}" logRewrittenUrl="true" />

This reroutes all requests to my servers ipaddress to my dashboard server. Note that this one only serves the /api part.

1 Like

Hi @kreef
Welcome to the UD forums.

Personally, i ran community on IIS on a dedicated VM for UD without problems.
There shouldn’t be a limitation on community edition to prevent external computers to connect to your dashboard (unless it was implemented with 2.7? Haven’t checked)
Sounds like you’ve installed the enterprice edition by mistake?

Publish and start-uddashboard should function, and be avaliable to all your computers on the local network (as long as windows firewall allows external connections on the specified port)

I did buy a license when i upgraded to 2.7 however, so i haven’t tested it on 2.7, but 2.5 worked fine.

1 Like

Hi there,

Thanks for your reply. Yes I believe I installed the enterprise version by mistake. When trying to uninstall it I get the following:
“PackageManagement\Uninstall-Package : Module ‘UniversalDashboard’ is in currently in use or you don’t have the
required permissions.”

I’m in administrator mode in PS and I don’t have any dashboards active, I think… I’m not sure how to remove them so that I can uninstall if they are indeed active. (I messed around with one or 2 dashboards on ports 10000 and 10001 respectively and as far as I can tell they are not currently up.

Any ideas?

Great tip, thanks :slight_smile:

Hey Kreef,

If you ran one from the command-line it could be running still… you can always do a
Get-UDDashboard | Stop-UDDashboard

Then try to do the uninstall for the module.

1 Like

Hi there,
Awesome, thank you very much, it worked!
I then ran:
Uninstall-Module -Name UniversalDashboard -force
and it is no longer there.

As an aside, I seem to have had both the enterprise and community versions installed, so I have removed both and will start with the community version only!

Thanks again!

1 Like

Modules just get installed in one of the $env:PSModulePath locations. I’ve removed the module folder from the installed location before. This effectively removes the module. I’ve never had any issue hosting either UD version from 1.3.2 forward to 2.7.0. Sound’s like the port was being blocked. localhost:port should always work provided the port is not being blocked. Also x.x.x.x:port works for me using the Community edition for all versions.