Role Based Access - Windows Authentication (AD)

Product: PowerShell Universal
Version: 4.1.2

I have an issue using Windows Auth.

I have it setup and configured, as i was logged in as admin i was testing the dashboard in incognito mode and the testing was good, when navigating to the app, i got a browser popup asking for credentials which worked.

However, when i’m not in incognito and sign out of the admin account then navigate to the app i don’t get the browser popup, instead i get a 500 error?

Tried multiple browsers and computers, all the same issue.

Any idea why it only works in incognito?

In addition to this, is there anyway to use a custom login page, like the forms authentication for active directory as that is much more use friendly / nicer ux.

You need to read the security on the docs page it’s all there

Check what version of powershell you using for your dashboard

I have read that however can’t seem to find anything about the authentication working in incognito Vs standard mode?

Sorry if I am missing something obvious.


Ah, i must have missed the bit about this

setspn -S HTTP/ myuser

That appears to have fixed the 500 error code in normal mode.

I will have a play with permissions now :slight_smile:

Thank you