Retrieving UA variables within a dashboard

Back in the v2 UD days, I used to either pull all my creds from cyberark and/or store any non secure variables in my dashboard ps1.
Now I’m setup on the latest shiny version, I’m looking at: Variables - PowerShell Universal
I’m reading we can use the built in variable and secret storage which is cool.

Following the guide, I’ve added my variables (a test secret and a regular variable).
In my dashboard, I’m just using $variablename but getting nothing back for either.
I’ve tried including the $ in my variable name and without (when adding to UA).
I’ve also made sure, I’m using the default environment and variables as ‘*’ defined (but I’ve also tried explicitly including my variables too).
I’ve tried restarting my dashboard and app pool too but still no joy.

Universal 2.4.1
Dashboard Framework 3.7.1

What’s your environment? I just tried in 2.4.1 with a 7.1.4 environment and it’s working there. I know we’ve seen issues with the integrated environment and variables in the past.

I left the environment as Default, so I assume that is Integrated. I’ll give it a try on 5.1 and 7

Yep that’s it, as soon as I changed to 5.1 or 7 its started working, and the issue re-presents when switching back to integrated

Ok. Thanks for the info. This is a regression. I’ll open an issue for it.

Edit: Variables are not working in the Integrated environment · Issue #646 · ironmansoftware/issues · GitHub

1 Like


I just want to report that I have the exact same issue as the user who opened this thread. I’m running PSU 2.7.3 (self-hosted, no IIS) and PowerShell 7.1.5. When I set the default environment to Integrated, variables aren’t usable in the dashboard. When I set the default environment to 7.1.5, variables are usable in the dashboards.

Ok. Thanks. I’ll re-open that issue and investigate.