Refresh Issue on New-UDTable

Product: PowerShell Universal
Version: 4.3.1


I am in the process of migrating from Universal Dashboard to PSU 4 - making good headway with most parts of it, its been a few days of messing about :slight_smile:

I have run into an issue with New-UDTable though.

Initially, I tried wrapping the “New-UDTable -Data” inside a New-UDDynamic script block with -AutoRefresh -AutoRefreshInterval 1 at the end of it. This works and displays the data I want - BUT, I cannot apply any filters or sorting to the table as every second it gets refreshed.

I am now trying the New-UDTable -LoadData { } method, and again I have succesfully populated the table with the data I need - however, it does not automatically refresh for me. I have tried wrapping it New-UDDynamic as before, and while it does refresh, the table goes blank for a second while the refresh takes place. Since it’s every second, it looks like its having a fit. Not ideal

If it helps, the data I am calling is in a $Cache:Data variable.

Any idea how I can achieve my goal here, which is to have a UD-Table that I can sort - but also automatically refreshes its contents?

Many thanks for any advice anyone can offer here!

bump Anyone any ideas here?

There are -AutoRefresh and -RefreshInterval params on New-UDTable, try those in conjunction with your -LoadData method, that way you won’t need the dynamic region

Thank you ! this appears now to be working! Appreciate you taking the time to assist.