PSU 3.3 - Script Output showing on a single line

Product: PowerShell Universal
Version: 3.3.0

I have just upgraded to 3.3 and ran a couple of reports, the output from the script is showing on a single line.

This is a script using PS5.1 environment.
The first line is an output from a function within a module.
The second line comprises of multiple Write-Output, all on seperate lines in the script.

1 Like

Can you please try clicking the “Hide Timestamp” button to see if you see different behavior?

1 Like

That initial screenshot was with Hide Time
I ran the script again and enabled timestamps prior to it running. This time it only showed the Function output.
If I toggled the show/hide after that I end upw tih the same results as the above image.

1 Like

Ah. I see it now. I missed the PS v5.1 tidbit. We can get this resolved.

1 Like

I have tested after upgrading to 3.3.1.
When I run the report, by default the time is hidden and I end up with this result.

Then If I toggle the Died time off and back on. I get the results as expected.

If you press F5 and refresh the page is all the output shown? Seems like the page stops reloading the output after the job completes.

I re-ran a couple of reports and they are all showing the output live without having to toggle or refresh the page.

Ok. Thanks for giving that a shot. I certainly noticed some weirdness here before where sometimes it’ll even say that the job didn’t produce any output