PSScriptpad Winforms Designer Failed to Create Component 'SplitContainer': System.NullReferenceException

Been running into an unfortunate issue with the WinForms designer on PSScriptPad. I’m unable to add some specific controls, even to brand new forms, including SplitContainer and ToolStripContainer. I get the following message:

Piped error: Failed to create component ‘SplitContainer’. The error message follows:
System.NullReferenceException: Object reference not set to an instance of an object.

I thought it was an issue with my installation at first, so I tried it across two physical machines and one virtual machine and I get the same result. I also tried it both using the Pro Tools VS Code extension and the standalone PSScriptpad.exe.

I’ve ran as admin and set my execution policies between bypass and unrestricted. No luck.

Tried to work around it by manually creating the SplitContainer object within the designer.ps1 and, while running the mainform dialogue displays the control, editing it through the designer does not.

Any advice?

EDIT: Tried previous versions of PSScriptPad.exe and they all seem to do the same thing… maybe I’m missing something?

Unfortunately, this is a bug that’s been open for a while.

The problem is that a service the split container requires isn’t registered properly and attempting to create it throws this error. I was not aware of the ToolStripContainer.

I’ll pull it into our next release’s milestone.

Thanks Adam, I hadn’t seen that issue report on GitHub and I thought I was going insane. Are you aware of any previous versions of PSScriptPad that aren’t affected by this bug or does it affect all versions?

I think that this has always been an issue.